Hackers Target A Critical Flaw In Internet Explorer

Those nasty beings had unearthed yet another security flaw in Microsoft’s browser that would give them the ability to install malicious software on vulnerable computers. The news of the exploit appeared on December 29 last year.

Luckily for most (and unluckily for some, I am sure) only versions of Internet Explorer 8 and under are affected by the flaw — both the newer versions, Internet Explorer 9 and 10, are safe. Phew!

The security exploit allows remote execution of code as well give attackers control of the vulnerable system if a user browsed a compromised website with an older unsecure version of Internet Explorer. Experts believe there are several such sites in existence, with more popping up constantly

Microsoft swiftly issued a workaround to help users stay safe, and then followed it off with a small Fix It tool for users of IE 8 and older, which can be downloaded here.

Dustin Childs, the group manager over at Microsoft Trustworthy Computing said:

“We encourage customers to apply the Fix it, an easy, one-click solution offered with Security Advisory 2794220, to help ensure maximum protection. Additionally, customers should ensure their anti-malware solution is up-to-date and follow good network hygiene practices, such as enabling a firewall, for added protection against threats”.

Internet Explorer 8 is most widely used by users that are still running Windows XP. If you are still on an older version of Internet Explorer, make sure you download and install the above fix.

Microsoft has been recommending people to make the move to a new version of Internet Explorer, and this current critical flaw is another reason for users to make the switch.

Please Leave Your Comments Below...